Start a new topic

Plays.TV not working? Possible Solutions in here

These are some of the solutions I've found after experiencing problems on my own machine. There are some issues I've seen other users having so might be of some use.

Error 1: I've installed AMD Gaming Evolved/Raptr and Plays.TV doesn't load.

1) Uninstall both AMD Gaming Evolved/Raptr and Plays.TV from your computer
2) Download and install the Plays.TV client seperately from here
3) Open to make sure it's working
4) Download AMD Gaming Evolved/Raptr from and install

Troubleshooting Plays.TV problems.

1) First of all open the settings by clicking the cog in the top right corner and goto the 'In-Game' tab, make sure none of the 'Hide' options are ticked. This way we'll get clearer indications of what's going on in game.
2) In the general tab make sure both 'My Session Video' and 'Video Capture' are turned on for now.
3) Boot up a game of your choosing

Error 2: I get no overlay in game at all.
Solution: This is most likely caused by lack of administration rights (might be specific to Windows 8.1). To solve this:

1) Close the Plays.TV client
2) Right click the Plays.TV shortcut and select the 'Compatibility' tab
3) Select 'Run this program as an administrator'
4) Open the Plays.TV client and try again

Error 3: You receive the message "Record error. Alt+tab out of the game for more information"
Solution: This is most likely caused due to a permissions issue with the default folder. (i.e C:\Users\Peter\Videos). There are two solutions to this:

1) Change the permissions for the default video folder.
- Locate the PlaysTV folder, it should be in your default Videos folder (i.e C:\Users\Peter\Videos\PlaysTV)
- Right-Click the folder and select 'Properties'
- Click the 'Security' tab, highlight 'Everyone' then hit 'Edit'
- Tick the 'Full Control' box then click okay.


2) Create a new folder elsewhere
- Open up one of your hard drives in Windows Explorer, create a new folder (i.e C:\Recordings)
- In your Plays.TV settings goto 'Folders' and under 'Game Video Recordings Directory' locate the folder you just created.

Error 4: I play CSGO or League of Legends, I have 'My session Video' turned off and 'Video Capture' turned on, when I load my game up I get no overlay at all.
Solution: Video Capture is actually working, but I believe there is a bug due to the CSGO/LoL integration that Plays.TV has. So unless 'My Session Video' is turned on then you won't see an overlay. You can either:

- Turn 'My Session Video' on, if you're worried about space just set it to the lowest amount


- Continue without the overlay. Try the hotkeys (CTRL+F3 by default), it should still save your recordings.

1 person has this problem

Thanks for the nice write-up! :D

If none of the above works, you're also welcome to send us a ticket and/or post on the forums.

Since I changed the quality settings fails to save the video, there's only sound. I've changed the settings back and forth and nothing helps. I've already tried reinstalling both Raptor and to no avail, which is a shame because it's a good program otherwise :(

@TaperHarley - Which game? Did you change anything in regards to Hardware for your PC?

The game is Star Conflict, I only changed the recorded video's resolution.

I don't find the "Video capture" option.

I can't record any LOL match it simply doesn't show anything on the client. Do you have any idea what it might be?

I run a vostro 5470 with Windows 7 BTW

@YoungCaesar - Could be several different issues actually. Have you created a ticket about this?

To send logs you just right-click on the taskbar icon, select Help > Feedback, fill out the info and make sure the checkbox is selected. Post back here to let me know you have sent it. 

1 person likes this

Hi @Verun thank you for the reply. Just sent the feedback and also opened a ticket for it

thank you

Most bugs are not covered in this article. First off the new update stops users from uploading. Anytime I save my clip it says uploading then gives me that white spin circle in the middle of the movie. Then after awhile, it will actually duplicate the video and stop uploading. Then I have two sessions, the one I recorded and the one that was edited. Only its not uploaded. If I try uploading the edited session it does the same thing.

Nothing will upload -.- Im getting fucking pissed.

@x0Z3ro0x - The walkthrough from the OP is not an official Raptr/ guide. We're looking into an issue where uploading is unable to proceed, but it makes a copy of the file to preserve it. I've replied to the ticket you created so I can take a look at the logs for it. Thanks for letting us know!

anyone know any better alternative software cuz this is useless

This forum post is a bit dated unfortunately. I have gone ahead and replied back to your ticket you created for further assistance.

I have a question: Whenever i want to save some clip from the game "Smite" i press the button i binded and it's says it's saved and stuff but when i watch the video it's so lagy so can someone help me or tell me what to do ?

@Skard - Typically means it's not encoding correctly. You may want to try updating your video drivers and see if it helps. If it does not, check to see if you meet the system requirements for Hardware Encoding.


hi my league no longer does highlights
how can i fix this issue?

also my friend has the same issue
i try reinstall everything is it a bug?