Start a new topic

Cannot record Overwatch

 Hello, I'm enjoying the Overwatch Early Access Beta, however nothing I do will make start recording overwatch.

Manual Record does not work

Switching to Automatic Record does not work.

I've tried all combinations, but nothing works. I play Heroes of the Storm a lot (another game that launches from the app), and records those games perfectly fine, however nothing happens when I try to record Overwatch. In fact I have not had a problem with at all when it comes to recording a game, until trying to (frustratingly) record Overwatch.

Only thing I could see when doing a quick google search about this problem was a post over 3 months ago and a mod said they were aware of the issue and a fix would be available a week later. Again though, that post was 3 months old.

6 people have this problem

I'm having the same issue. I saw that 3 month old post too but that's all I found on the subject.

I'm also having this issue.


Not getting any visual feedback at all, however if I go into the client it says I recently played Overwatch.

A keybind detection issue maybe? I'm stumped

So I confirmed that disabling the OSD for RivaTuner Statistics (MSI Afterburner) lets it work in Overwatch. Which is really weird because in Dark Souls 3 RivaTuner doesn't conflict at all, works fine.


Having the same problem, does anyone found a fix? Not using MSI Afterburner btw.

NEED A FIX NO msi no raptr still not recording overwatch nothing on the net


Same as banana. It's getting a little frustrating.

Only way I can get it to run is by disabling MSI Afterburner and RivaTuner. works fine in all my other games with these two applications, but not in Overwatch. Hoping you guys have seen this and are working on a fix!

Not using MSI Afterburner or Rivaturner, still not recording.  Please fix!

3 people like this

Have the same poblem, not using MSI Afterburner or RivaTuner. Really want this fixed :(

Also have this problem...

My friend & I both have this issue as well. Any fixes?


1 person likes this

Same problem here. Not using Raptr or RivaTuner or anything else, just vanilla Works perfectly fine for League of Legends though...

Same trouble here, not recording in Wow or Overwatch but no problem in league or cs or diablo 3

Had the same problem.

I'm running W7 with and AMD videocard.

I read a clean reinstall of would fix, but it didn't. I actually gave up thinking PlaysTv would bring and update and fix it. Talking about Updates, I was trying to make a program work and it required some windows updates, had 120 pending updates so I just installed them all, later that day I opened Overwatch and "Plays.TV started recording" showed up!! I'm not sure what update could have fixed it. I guess the update "KB2670838" did. But try it out.

2 people like this
Login to post a comment