Start a new topic

War Thunder + some other games simply do NOT record.??!!

Hello. I have been recording my gameplays for quite awhile now using Plays.TV. But when I tried recording Wolfenstein: The new order/ The old blood, it wouldn't record it... Not manual nor automatic works. Why isn't the new Wolfenstein supported?? It's like one of the most popular games ever... I could record War Thunder without problems, but then an update came a few days ago and now I can't record the game. Works only on some games like Battlefield 4 etc...

Note that it says that War thunder is compatible with Plays.TV.

My PC components couldn't possibly be the case with this problem, it's just not logical... But i'm gonna mention them just in case.

CPU: Intel i7 6700k
GPU: R9 290
PSU: Chieftec 850W 80+ Gold
RAM: G-Skill DDR4 3200Mhz 
HDD: 1TB WD Blue
SSD: Samsung EVO 250Gb

Please help me get this solved as soon as possible because it's very frustrating knowing that something which should work doesn't work.

Thank you and have a nice day.

3 people have this problem

Hey there, 

War Thunder we should be able to support. I haven't seen a huge influx of War Thunder issues lately so it's possible it could be having issues locally. Did you make any changes to your PC recently? Mostly to changes in the boot drive, or where the game was located.

You could try recreating the problem and sending in a ticket with logs attached as well. To send logs you just right-click on the taskbar icon, select Help > Feedback, fill out the info and make sure the checkbox is selected. Post back here to let me know you have sent it. 

As for Wolfenstein the New Order and/or Old Blood, there were known issues when we tested it that was causing the game to crash. As a result, we disabled the recording function for that game. We have continually tested it for different methods to get it working, but so far it hasn't had any positive results yet.

1 person likes this

Thanks for taking your time to deal with my problem. Really appreciate it. I sent Plays.TV a log just as you advised me. Now i'm waiting for a response. Yes, it truly is weird that War Thunder isn't being recorded... I tried reinstalling the game and it doesn't help. 

Thanks for explaining about Wolfenstein. Sad to hear it... it's an awesome game. I hope it becomes recordable as soon as possible. 

Thanks again and Have a great day.

Just replied back! Thanks for sending that in!

Its NOT a local issue, as the exact same thing happened to me. Been using PlaysTV for ages to record my war Thunder, latest update? Nothing, neither auto or manual will work.

Having same issue,  But with GTA 5,  Worked great till the last update.

I've tried reinstalling both PlaysTV and War Thunder, no effect. If there was a way to roll back to the previous version I would because this latest update has killed the program for me as all I had it for was recording my War thunder matches, now I have to scramble to find another program to do the job.


I am having exactly the same problem with War Thunder, everything else runs fine, I have also ried reinstalling and have the same issue, already sent my log file and still awaiting for a reply.
This is quite frustrating as I only have a limited time to record War Thunder videos.


Yup i'm having the same issue.

I've always been recording war thunder with but since few days , after an update i guess, it doesn't work, and i tried to fix this issue for 30 min.

Most of my games work perfectly fine , record them (cs:go , rainow six, ...) but not war thunder. Hope our tickets will do something about it and they will patch it.

same thing by me. Yesterday update raptr and my R9 270 drivers, since this time i can't record anything with
I even record all games whit, it works pretty perfect. But now....

I try to uninstall all drivers, raptr and, but nothings change. I clear renistry manuall and delet all, but nothing.

Is it posible, to download an old Version of, so i and the others can try this way. I search on Site and google, but found only the installer, that download the newest Version.

Please, give us a opportunity to download an older Version.


1 person likes this

I have the exact same issue with War Thunder. PlaysTV records every other game but War Thunder, tried re-installing Raptr, PlaysTV and War Thunder, but still no effect. Hopefully that will be fixed soon..

1 person likes this

I have tried going to previous drivers, reinstalling the game, it simply will not work in the latest PlaysTV. Please please PLEASE let us download a previous version.

We don't have a great method for downloading an older version (since it just auto-updates). However, I'm not sure a previous version of the client would help. It does definitely seem like something is wrong that is affecting multiple users. If I had to take a guess is it has to do with the detection of it. 

For those that are getting this issue, can you recreate the problem and send in logs?

To send logs you just right-click on the taskbar icon, select Help > Feedback, fill out the info and make sure the checkbox is selected. Post back here to let me know you have sent it. 

1 person likes this
Log File is send


Maybe i had a other thought for solution. Is it posible to install raptr and from Orginal DVD from my R9 270 box? There where old drivers, but there is include. On this way i know about that was previously not known to me.But i'm not shure if here is a webinstaller too


Login to post a comment