Start a new topic

Static in my headphones when recording

When I record I hear some very short static once every few seconds. It's so annoying that I cannot use Plays.TV. The audio on the actual recordings are fine.


It wasn't like this when I first got my RX 480. In the beginning I was a pretty happy Plays.TV user.


I've reinstalled the latest drivers/software for the GPU side and my headset (Logitech G930). When I run the XBOX DVR there's no static. I never had static when I was on Shadowplay on the previous card. I've tried putting the receiver in another USB port.


Can anyone suggest anything I can try? 


I assume it's worked for the headset before? You may want to try changing the USB port, or at least unplugging it and back in. Typically we don't see this type of issue where the audio has static WHILE recording. Have you also tried multiple games?

Yeah I've tried it all. I've also taken another SSD to just do a quick fresh install with nothing else plugged in.


I've found that the biggest culprit is Logitech's Overwolf, so I'll uninstall that. I still get static at 1080p60 for some reason. 720p60 and 1080p30 are almost perfectly fine.


The more sound a game has the more prone to static on that 1080p60 so for example Overwatch has a tonne whilst CS:GO not so much.


I'll live with 720p60 recording for the time being unless someone else has a better solution. This definitely seems like a weird one. I mean a fresh Windows install, changed all types of USB configurations, reseated my GPU. I could try going for earlier versions of the drivers and PlaysTV but that will be for another day as I bet I'll have to search for those downloads. I've already spent so much time and like I said 720p60 works.


Unless someone has something else to try?


Windows 10 64-bit

RX 480 latest Crimson drivers

Logitech G930

Logitech G700

Do you have a link to a video that shows the static? I'd be interested to see what kind of static you're hearing.

Login to post a comment