Start a new topic

Stuttering in recordings but not gameplay


When I try to use to record while streaming it results in choppy recording with lots of skipped frames and stuttering. 

I do have an iGPU and I've checked the logs of and it has hardware level 1 recording meaning I'm using my GPU.  

I'm currently using and i5-4690k clocked at 4.4ghz and a Asus 7970 Matrix Platinum.

I've tried lowering the bitrate/FPS/capture destination of recordings but nothing seems to help, there is lots of hitching and stuttering in the playback, even when played through an external player such as VLC.

This is a recent problem and nothing in my setup has changed

Can be seen on the below video at 2 seconds

And again at 3 seconds

How often would you say it happens throughout an entire recorded match?

Does it seem to only happen with Dirty Bomb?

I'll request logs in the ticket you made about this issue.

Hi Verun,

It happens very regularly throughout the whole recording several times a minute but with no real pattern, I just have to hope the clips I bookmark don't have the lag in them which is frustrating.  As mentioned, this is a new problem as I'd been using with no problems for quite a while with no real problems until the past few weeks/months.

I created this thread as when I submitted the ticket I assumed it was due to running OBS simultaneously but further testing shows this problems with no other background programs running other than Dirty Bomb and the Steam client.

I've sent the logs from my most recent session and included the times of the recordings in the comments.

Thanks for the swift reply

Try this... When the recording overlay comes up when you enter the game. ALT+TAB and then goto task manager (Ctrl+Alt+Del) look for the process that is activating the recording. ( I forget the file name) and make sure you put it's priority by right clicking and setting it to Real-Time.

1 person likes this

I've actually come across that workaround from another thread and it seems to be working now.  I'm using a program called Process Hacker 2 that lets me set the priority of the two encoding services to realtime and save them so I don't have to do it every game.  Would highly recommend to anyone else having the problem!

Just wanted to chime in and say that this worked great - the PlaysTV encoder processes (both regular and 64) are set to run at less than normal priority, so Windows isn't giving them the resources they need. Setting them to Real Time works perfectly, although without Process Hacker you need to do it every single time you start a game.

Login to post a comment