Start a new topic

For those having Lag/Choppy videos problems

Months ago, Plays.tv was working properly until some updates messed up its configurations, so after playing my games, when I wanted to look at the videos, every so seconds the video will rip/lag/choppy or loose fps sometimes sound as well.


For my case, after an hour looking for the problem, I had to change permanently the default setting for the priority of the process that makes the video. In this case is process of the encoding server plays_encoder_server64-116096.exe I had to set this on Realtime. The problem was instantly fixed. To do this in windows 7 or vista you can change it on the Task Manager > Details > (you need a video being recorded) plays_encoder_server64-116096 or whatever your encoding server is (also it changes with every upload) > right.click > save priority Realtime (putting it on high will lag your game). In windows 8-8.1 you need to download a program for this > http://download.cnet.com/SetPriority/3000-2094_4-10473386.html > works just fine. I dont know about windows 10. Hope this helps.


This makes a massive improvement on my recordings as I've been having exactly the same problems for the past few months as well.  While not as perfect as it used to be this is a huge boost to my recording quality as I previously had to just hope my clips weren't affected by the lag in recording.  


Thanks for sharing this!

Unfortunately this fix doesn't seem to work on the latest update.  I had to reapply the priority to the encoder again but even then it still results in laggy/choppy recording when viewed

When the latest update happened, it began having problems again. What i did is that i told the little program, "setpriority" to put the new encoding servers proccesses to RealTime again. You see, every time there is an update, the encoding servers also get updated. There are always 2 of them, one 64bit and the other 32bit. You have to set them both to RealTime priority on the task manager. If they keep reseting to below average as it was my problem, i downloaded "setpriority" to help with that issue.


1 person likes this

I set everything to do with the plays recording encoder at realtime and it seems to have resolved the issue for now.  I'm using Process Hacker 2 as I'm on Win 8.1 64bit and this lets me save the priority as realtime for future use.


Cheers for your help and suggestions man

This doesn't seem to hep me, my PlaysTV was running fine until November last year, since then it has been lagging like crazy when playing counter strike, and this started happening right after the "smart-kill" thing happened. I'm so pissed off about this, and I don't know what to do.

@marc5075


As I have stated, most of this fix is for windows 8.1 but also some people using windows 10 have found this useful. The thing is that the encoder's process is run below average, but there are 4 problems.


First, if the encoder does not work well, it will lag. Therefore you need to put it at Realtime in process priority. This is done in the task manager.


Second, every update of the program will create a different encoder that you need to apply the First step provided above. It also helps if you set up your video card to render this encoder. With Nvidia is easy, with the Nvidia control panel.


Third, If using windows 8.1, you cannot save the Reatime option and every time you try to create a video, say every time you get into a csgo match, or a league match, the encoder will run default to below average, therefore you need a program to make it default to Realtime, like to ones posted above; SetPriority, ProcessHacker and others.


Fourth, there are 2 types of encoders as well. One is 32bit and the other is 64bit. Both need to be set up to Reatime and of course it helps if they are also run by the Video card and not the integrated Intel card if you have it, which probably you do.


Hope it helps.

Oh also, it may consider it a "Fifth"; The encoders are .exe, so setting them to run in administrator privileges, helps. 


Bonus: To easily find these processes they are named plays_encoder_server(xx)-yyyyyy. Where the x's note if it is 64bit or not, and the y's is a bunch of numbers. Also the process when it is running will show up at the "details" tab in the task manager (on windows 8.1, unsure if also on windows 10), not on the process tab, as in the "processes" tab it will show the plays.tv client only.

@Nozferatus I wish this would help, but as I got laptop there is like almost no settings under the Nvidia control panel..

I have a laptop as well... Go to manage 3D settings, there you should be able to look up the program and set it up to run with the Video Card as default


@Nozferatus meh, doesn't work, I give up xd


Thanks man :), it worked for me. Im using Windows 10, so didnt have to install anything :)

I know I am replying late but I am a windows 7 user and I am having this problem badly. But the real issue here is when I go to change the priority of the encoder thingy it says it cant be changed. But no it isnt forbidding me from it like trying to change the priority of the plays ep64 exe but just saying it cant be changed. Any help?

Login to post a comment