Start a new topic not linking to account or recording League of Legends

So I've loved and used it constantly to watch and review my games for educational purposes (and upload the occasional play).  Anyway, for some reason one day it simply stopped recording League altogether.  Thinking I needed to relink it, I unlinked my account and restarted the League client, only to have the client not detect that I had logged in, so the automatic link did not occur.

Reading up on it, I found two suggestions:

(1) Repair and/or reinstall League.  I did both of these, but the client still does not recognize League's client.

(2) Record a game manually at which point when you try to upload a video it will ask to link your account.  I tried this, but the client doesn't even seem to recognize that League is running.

(3) This wasn't a suggestion, but I tried to uninstall and reinstall as well, with no success.

Has anyone had this issue?  I can't seem to find anyone who has these specific symptoms.  Most people have a linked account but can't get a recording or can get a recording but not link their accounts.

Anyway, thanks.

2 people have this problem

We're looking into an issue potentially related, but hard to say. Do you know if League of Legends actually records for you? Either way, I always recommend anyone that is having an issue to create a ticket with logs attached so we can look deeper into the problem.

To send logs you just right-click on the taskbar icon, select Help > Feedback, fill out the info and make sure the checkbox is selected. Post back here to let me know you have sent it. 

League does not record at all for me, manual or automatic. Other games do, however. When I get home today I will work on the logs and create a ticket. Anything else I should try? Thanks for the reply.

I have exactly the same problem, PlaysTv record every game I play except League of Legends, I sent a log, still waiting for a reply. 

@devante - Preferably when you get home, play a League game and then play a different game that does record. After that, send in your logs. Thanks! :-)

@RivenMech - Got your logs, thanks for sending them! You are getting the bug we're seeing. I will do my best to keep you posted on our findings.

I'm getting the same problem as those two.

Thanks for the feedback.  I played 6 League games tonight, none of which were recorded.  I started up Minecraft in between just to show it would record.  I submitted a ticket (#47072) and sent logs via the client.


Guys can you tell me which lol.launcher you use? I also had that issue and i was opening the launcher with lol.launcher.admin.exe. did not recognise any league game i was playing. So i disconnected my lol account. But never showed up to connect my summoner again. Then i started the normal lol.launcher (not the admin version). After i went in some game asked me to link my account again. And also recorded every game.



Look up which lol launcher you are using, if it is the lol.launcher.admin.exe close the client and try lol.launcher.exe! After you connect to any game (even spectating mode), should asked you to link your account. It should also show up one new video (which was the spectating one).

Thanks for the suggestion, I will try it this evening. I am unsure of what launcher I am using without being at my PC.

I found another possible solution. I tried running PlaysTv as administrator and now its recording League of Lengends

Yeah thats also one possible solution. Maybe if you start lol.launcher.admin and isnt started with admin rights. It has no rights to record league of legends. (even tho it worked before)

With the reports of users being unable to record, we're so far having luck with them coming back and stating elevating the client as Administrator solves it. Feel free and let me know whether it works or not for you though.

Login to post a comment