Start a new topic

Overwatch game identification issue

I noticed today that is not correctly recognising Overwatch.  The Overwatch test region client is correctly identified and all the integrated functionality (auto-bookmarking PotG's and matches) works, but the live version shows up as "Overwatch Application" and no highlights or bookmarks are created.

4 people have this problem

Hi, I'm, getting this issue too, but for both PTR and Live.

We're looking into solution, but a very easy work around that we found for most users is try opening Overwatch.exe directly from it's install location, and bypassing the Launcher. After that, it manages to detect and should record normally. It has even started working for some with the Launcher after that.

Unfortunately that's not resolving it for me, I'm going to try reinstalling the game as the PTR client did start working for me so it must be a configuration issue.

You could also try using the Scan/Repair tool in the launcher.

Got the same issue, PTR identifies fine, but not the live client.

@xRuneXero - Did you try the instructions I posted earlier?

I have, I got it to work just now and I'm further testing it out. I'll post again in a minute or two with news.


Okay, here's what I did.

  • Uninstalled PTR and reinstalled live client - Didn't work.
  • After that I turned off MSI Afterburner/Rivatuner, Gedosato (if you have it) and launched directly from .exe - Also didn't work
  • Turned off nvidia thing from the toolbar (right click nvidia icon, exit), also unlinked my OW account in app and logged out and in - It worked!
After that, I relaunched MSI Afterburner, Gedosato and nvidia stuff and it was still fine so, in conclusion, I think unlinking OW account and relogging on app did the trick. It works by launching the game normally on too, and I'm on Windows 10.

Didnt help to me((( 

any news on this? still isn't working on my computer :/


I also have the same problem, still isn't working :(

Typically, any issues where Overwatch is appearing as "Overwatch Application" and/or is not binding your Account is tied to the game not detecting correctly. Our recommendations are:

  • Disable any 3rd party software that might also be trying to hook into the game. This includes recorders, chat overlays, screenshot programs, overclocking software, etc.
  • Try using the Scan/Repair Tool in the Launcher for Overwatch
  • Elevate the client as Administrator
  • Uninstall and then Reinstall Overwatch

If none of that works, I'd recommend making a ticket with logs in our system if you have not done so already. 
To send logs you just right-click on the taskbar icon, select Help > Feedback, fill out the info and make sure the checkbox is selected.

for me only worked when I run as administrator

Login to post a comment