Start a new topic

Plays.Tv wont open or it's already "open"

Since the update I can't open plays.tv. I tried the antivirus exception, compability and so...


3 people have this problem

Are you using Windows N by chance?

We're hearing more cases where users are unable to open the client and it's due to not having an up-to-date Media Feature Pack: https://www.microsoft.com/en-us/download/details.aspx?id=48231

I'm using windows 10, it used to work, but suddenly it updated and stopped working. I have deleted the entire thing and my graphic card is updated as well...

Do you know if it's Windows 10 N?

And the update you mentioned, is that 1.21? The one released on March 30th?

I've tried installing the Media Feature Pack, and it still says its opened, but the client doesnt appear

No idea... I dont have Win10N. I have the normal one, anniversary.... 

Same here.

This keeps happening every once in a while with new patches, and it strikes again with this new patch, I close the client from task manager then go back to open it, it takes a minute then pops a window saying "client already running". I've tried clean installing plays, raptr, my antivirus, checked firewall, even clean installed my amd software, checked plays tv client properties, compatiblity, and every possible solution I could find online. 

The same thing happens with raptr.


Window 10 home.

Only install the Media Feature Pack if you have Windows N. 

Other than that, if you're getting this problem, I'd recommend making a support ticket in our system. It allows better tracking and easy linking between the customer ticket and out internal bug ticket. 


Once you've made a ticket, I can provide further instructions for how to manually send in logs files. 

I did make a support ticket 3 days ago,on April 7th, it's still being processed.

Just replied to the Plays.tv one. If I had to take a stab; whatever is stopping one client, is stopping the other one.

Are there any patches coming soon? :(

This issue has been going on for several years, so probably not. Not until we can fully determine what is stopping it, and know whether it's even us.

No, i mean it happens once every few patches, but you can work around usually, if not, it gets fixed itself the next patch, i know this cuz release notes don't mention this problem being fixed.

Thanks anyway.

Any luck? Anybody?

Aqui a mesma coisa ...


abri um ticket eles so falaram para se poder usar outro aplicativo por que nao sabem arrumar ..

Login to post a comment