Start a new topic

High quality recording uploaded as lowest quality

I have all the settings on highest and whenever i upload them to my playstv profile they come out as 480p when i record in 1080p with 60fps and highest bitrate. how can i fix this?

Sometimes you may have to wait a bit before the full resolutions come out. However, also make sure that you don't have 'Optimize Videos for Upload and Share' enabled:


ye i dont have that on, ive been uploading clips for almost 2 months now and it still hasn't changed.

What resolution are you playing the game at?

I've got a same problem

Kind of the same issue here.  I play @ 1920x1080, all my settings are cranked in-game and on Plays.TV - Video says its published @ 1080p 60fps (which it probably is) but the quality is a pixelated mess.  The competitor of Plays posts in perfect quality, but is limited to 30 seconds.  I enjoy the borderline infinite clip size of Plays, but it would be fantastic if the quality issues could get sorted.

@Bigmark - Can you provide an example of what it looks like?

Hey Verun,

This actually worked itself out.  It took a few hours for the quality to render, despite saying it was 1080p.  Ever since then, it has been only a few minutes to fully render @ 1080p 60fps (with good quality).  

Computers eh, who knows.

Here is a sample:

I could nit pick and say it's still not as good as others, but honestly this is beyond acceptable for me and I am sure the rest of the community.  Also for others to note, it's the only service with longer than 30 second clips and it still remains free :)

Thanks again Verun,


Login to post a comment