Start a new topic

After windows 10 fall update, Playstv is broken.

Like the title says, after installing the windows Fall update, upon opening the Plays.TV client, I am greeted with a message that says "Recording currently unavailable (missing system files)."

Visiting the FAQ tells me to install a media resources pack, which I already have installed, but also re-installed to double-check.  Still it does not work.

Does anyone have a fix for this?  Or do I have to wait for Plays.TV to fix the problem Microsoft created?

(6.08 KB)

I have the exact same problem, have you found a fix for it yet?

After a 3 day exchange with tech support and even being elevated to an engineer, the solution I was given was to uninstall the update

The Windows Media Feature pack is for Windows N or KN. Does that match what version of Win 10 you are running?

There is a newer version of the Media Feature pack released in November 2015. which can be found here:

1 person likes this

guys i found the solution after searching for 3 days - the right solution was : ( instead of installing the N or KN windows media pack , try to install the N media pack which is in this site )

i did it and it worked for me ! try this guys ! and like this comment if it worked 

Login to post a comment